We experienced delay in the delivery of some outbound emails
Incident Report for DANAConnect
Resolved
This incident has been resolved.
Posted Sep 14, 2023 - 21:03 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 14, 2023 - 19:43 EDT
Investigating
We have detected that one email server has a technical problem. We are routing all the new messages to different email servers
Posted Sep 14, 2023 - 17:54 EDT
This incident affected: Outbound Dispatchers (Email platform).